Unleashed - Client Roaming Issues

Edited

Problem Description:

Certain devices such as iPhones and Android, for example, suffer from poor roaming performance, and often this results in an unstable connection or poor performance.

This can also happen on laptops too.

 

Cause:

This is down to the device not roaming to the nearest access point and whilst we cannot control how the device roams we can make the AP enforce strict criteria that the device must meet in order to be connected to it.

Whilst this seems drastic it's what all wireless vendors do, in effect you change the BSS-Minimum Rate to make the device look for the nearest access point.

 

How to fix:

Please note that the must be actioned on the master access point and if the configuration ever changes on an SSID the set of commands below must be re-entered.

 

Step 1

Using SSH connect to the Master Access Point and login.

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Step 2

Entering configuration mode and then type in the name of the WLAN you wish to edit. The WLAN name is case sensitive so must match exactly.

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This will tell you that you have loaded the WLAN service if successful

Step 3

Change the BSS-Minimum Rate to either 6, 12 or 24.

We often use 12 as this suits most environments, if you find that devices cant connect in certain areas then use 6.

Commands

bss-minrate 12

exit

exit

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Step 4

To verify the change has taken place use the command "show config" and look for the WLAN you amended.

As you can see below the change was successful.

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